Jump to content
Search Community

Website No Longer Working On iOS Chrome - Created in Adobe Edge Animate & powered by Greensock

MGTH test
Moderator Tag

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Hi all .. this is not really something I can make a codepen example of .. But I could really do with a wee bit of help diagnosing whats up please !!


The website was created in Adobe Edge Antimate and powered by Greensock .. It was my first attempt at a site away from Flash and had been working happily across platforms ( mobile and desktop ) for over a year and a half .. Now the site no longer works on iOS Chrome and possibly some other platforms that I don’t have access to.


I really don’t know how to start diagnosing this .. here is what I’m seeing:


- iOS Chrome

- Loads the edge animate preloader

- Preloader finishes

- Site hangs on green screen which is where Greensock should kick in


It appears to me that the edge side of things is ok .. but chrome isn’t liking Greensock for some reason .. I may be wrong ?! 


I have tested on:

- mac versions of - Safari - Chrome - Firefox - Opera - iPhone - safari - ALL GOOD

- iphone Chrome - ALL BAD


I’ve put the site up on my server .. here’s a link:



Would really appreciate if someone could point me in the right direction on how to diagnose what up.





Link to comment
Share on other sites

Hi Jack .. thank you for the support .. its much needed :)


Think I’ve possibly confused things by saying .. “I’ve put it up on my server” .. it’s not a personal server .. if that is what your thinking ?! 


I get the same result testing the site where it is hosted which is different from my sites hosting .. sorry if I’m getting the wrong end of the stick ?!





Link to comment
Share on other sites

Hi Jack


Server .. I Had a wee look in the cPanel of my site to check out the MIME Types .. in the System MINE Types it already has this listed:


MIME Type - application/javascript

Extensions - js


Which I think is what the StackOverflow diagnosis is suggesting as a solution.


Chrome's Dev Tools: message - Resource interpreted as Image but transferred with MIME type application/javascript: ..


This seems to be something to do with yepnope .. I think edge uses this to load in external js .. but from what I’ve read so far this is an expected message and shouldn’t cause any issues ?! pretty sure i remember this message when I originally made the site and the site worked fine on iOS chrome back then.


Sorry if this isn’t a Greensock problem .. I appreciate your time and the support you give is great !!





Link to comment
Share on other sites

Yeah, it doesn't seem like a GSAP problem at all, and it's likely either a server-side issue (as that StackOverflow diagnosis suggested) or it is an Edge thing (perhaps with YepNope). I'm not much of an Edge expert unfortunately. 


Did you try loading the same files on a completely different server where you know you've gotten other Edge files to serve successfully? That might help rule that out at least. 

Link to comment
Share on other sites

Cheers .. yep its on a couple of servers and use to work just fine on them .. I only picked up on the iOS Chrome issue a wee while ago .. it was all cool before this ?! 


Not sure where to go from here .. any Edge people out there and does anyone know what I can use to do some iOS Chrome debugging ??



Link to comment
Share on other sites

Hi .. Diaco.aw & Jack .. Just a wee update on the problem I was having .. I still don’t know exactly what the root of the problem was but I have made some progress.


The site was originally created in adobe edge 1.5 .. since updating to latest version and publishing from it it has brought the site back to life again in iOS Chrome .. I think the issue was with the edge preloader ( lots of negative comments about it online ) and how it was loading in 3rd party js .. it’s still not perfect needs a bit more tweaking .. but it’s working :) 


Just wanted to thank the two of you for your help .. ( even though it wasn’t a Greensock issue ) .. really appreciated !!





  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...