Jump to content
Search Community

Paid scrollsmoother behaving differently to codepen version

jsoares test
Moderator Tag

Go to solution Solved by GreenSock,

Recommended Posts

Posted (edited)

I've been developing a project with ScrollTrigger, ScrollSmoother and SplitText using the free demo version on codepen. After purchasing the ShockinglyGreen membership and using the full version the project was behaving slightly differently


It's odd that the full version will behave the same if I change the data-lag from 0.5 to 0.75 in the demo. I've noticed codepen uses Scrollsmoother 3.12.0 whereas I can only find 3.11.5 with the membership


Is this the expected behaviour between the different versions or am I missing something? Also where can I find the most recent full version of the different plugins?


Edit: It seems multiplying all the data-lag by 1.5 makes it look the same but it's still odd


Here is a minimal demo using the codepen version

See the Pen mdzvJWQ by jmorgadosoares (@jmorgadosoares) on CodePen



And a demo using my self hosted version

See the Pen YzJBPLx by jmorgadosoares (@jmorgadosoares) on CodePen

Edited by jsoares
Link to comment
Share on other sites

Hi there!

Thanks for being part of club GreenSock.

3.11.5 is the latest full version - codepen is using an unreleased beta (which is still being worked on) So that's why you can see a difference. We should be pushing it out soon though, with a new ScrollSmoother feature and some bugfixes. ☺️

@GreenSock - (Tagging you in here in case it's behaviour you're unaware of) 


See the Pen vYVbNpO?editors=1010 by GreenSock (@GreenSock) on CodePen


See the Pen MWPLaQG by GreenSock (@GreenSock) on CodePen

  • Like 1
Link to comment
Share on other sites

That's so obvious! I did didn't even think to check if both versions were compatible  🤦‍♂️

Thanks for pointing that out. Both versions work the same for me if as long as I use the same version of both ScrollTrigger and SmoothScroll.


However I noticed the markers are not behaving as expected on 3.12.0. I don't think there are issues with the actual triggers only the markers


Edit: the start marker works as expected the other ones are pinned to the bottom


See the Pen XWxGJQJ by jmorgadosoares (@jmorgadosoares) on CodePen

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...