Jump to content
Search Community

Transform Manager bounds incorrect v2

freediver test
Moderator Tag

Recommended Posts



I just found a bug that looks like this one : viewtopic.php?f=3&t=1466

Here are the steps to reproduce it!


Step 1 :

Go to http://www.greensock.com/as/swf/Transfo ... 3_Demo.swf


Step 2 :

Select the blue earth image


Step 3 :

Rotate the blue earth image to an angle of 0°


Step 4 :

Move the blue earth image at the bottom right corner of the transform area


Step 5 :

Stretch the blue earth image on the entire transform area, be careful to stretch it at the maximum



Step 6 :

Click outside the transform area to deselect the blue earth image


Step 7 :

Click on the bottom left corner of the blue earth image and reduce it

--> You can see that the blue border around the blue earth image is not situated entirely over the image



Step 8 :

--> Sometimes the blue border is not at all above the image



!!! If the step 7 does not work, try again by the step 5 : the bug is hard to reproduce but exists !!!

Link to comment
Share on other sites

For the life of me I can't seem to reproduce this even once. Are you using the latest version? Any chance you could take a video screen capture of the issue happening? I followed your steps faithfully many times and couldn't see the issue at all.


Maybe it'd be easier for you to reproduce if you just created a SUPER simple FLA that has things already set up exactly where they need to be and then I can just publish, click, and drag in some direction to see the issue (just a guess). Any chance you could post an FLA like that? Again, the simpler the better.

Link to comment
Share on other sites

I'm baffled - I cannot figure out how to reproduce this. I've tried for a long time at different angles, etc. and it works perfectly every time for me. Can anyone else reproduce this? I wonder if it's a bug in your Flash Player or something. What version of the Player are you running and what OS? There's also a chance that the piracy prevention software I used to scramble the swf might be causing the issue too. Have you been able to reproduce it in your own project? Are you using the latest version of TransformManager?

Link to comment
Share on other sites

I'm using :

- Flash player debug (version 10,2,152,32) and Firefox browser (version 3.6.16)

- Flash player standalone (version 10,1,103,19) and Chrome browser (version 7.0.517.44)

- Windows XP SP3


I reproduced the bug on my current version of FTM (version 1.911) and on your demo swf (I dont't know what version of FTM is here http://www.greensock.com/as/swf/TransformManagerAS3_Demo.swf ?).


The bug occured often when stretching the image at its maximum and when its rotation angle is small...

I'll try this week to make a sample AS3 application to determine these steps.

Link to comment
Share on other sites

My 2c.


Although i also was unable to reproduce the results, i have had something similar (which might be related).

If the object is scaled by code (not TransformManager), and is not updated (i.e _manager.updateSelection()), then the handles get out of step.

Perhaps the effect of rotation and rounding (i.e really small numbers, rounded over and over) makes it get out of sync marginally enough to be able to see the problem?



Link to comment
Share on other sites

Ok I made a new video to show you all the steps to reproduce the bug.

Note that I realized the demo here : http://www.greensock.com/as/swf/TransformManagerAS3_Demo.swf

You can watch the video here : http://dl.dropbox.com/u/2898683/2011-04-07%20transform_manager_as3_incorrect_bounds_1.avi


You can see at this time (~35s) that I try to rotate the image at a small angle (Maybe between 0 and 2°) and finally stretch it to its maximum. When resizing it, the bounds are incorrect!

Link to comment
Share on other sites

  • 1 year later...

What version of TransformManager are you using? And can you show me a video or specific steps to reproduce the problem? I have tried many, many, many times to see this "bug" but I can't seem to get at it even once. It's extremely difficult to troubleshoot an issue that I can't reproduce on my end, so I'm hoping you can help me get my hands on a set of files that I can publish on my end to consistently see the unwanted behavior.

Link to comment
Share on other sites

Guest ChromeDemon

Flash Player 11 has the same ...


When I export your Demo.fla i used: (Latest Transform Manager)


Mac OSX Lion, Target Flash Flash Player 10 and 11. Bounds are not correct and buggy (When I target for Flash Player 9 bounds are correct)


Hope that helps





Link to comment
Share on other sites

Have you tried publishing from a Windows machine? Just curious because this sounds like it might be a Mac-related bug that I have no control over :(


EDIT: I just saw your other post confirming that it looks like a Mac/Apple issue http://forums.greensock.com/topic/6315-mouse-pointer-disapperars-in-flash-pro-cs6/page__pid__22717#entry22717 so I'm glad to hear that, although I wish that issue didn't exist at all.

Link to comment
Share on other sites

Guest ChromeDemon

Windows 7, Flash Pro 6, target Player 10 and above, no issues. Bounds are correct. Another MAC OSX issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...