Jump to content
Search Community

Problems with registerPlugin

smenegassi test
Moderator Tag

Go to solution Solved by GreenSock,

Recommended Posts

  • Solution

Because you had the old version 2 URL in there :)

// BAD:

// GOOD:

(notice the "3" at the end)


I'm curious where you got that URL from. Perhaps there's a template we need to update somewhere(?)

  • Like 2
Link to comment
Share on other sites


It is not working locally. I download GSAP 3 with bonus files from my Shockingly Green account and it still comes, I guess, with an old version of CustomEase and CustomWigle.  Locally I still have the same error. There is no CustomWiggle3.min.js or CustomEase3.min.js

Thanks again


Link to comment
Share on other sites

Hey smenegassi. The only reason why the 3 is necessary on CodePen is because it is the special version of the plugins that's to be used on sites like CodePen. The 3s areonly there because the URLs were the same as the old versions so we had to add a 3 to the files that are also in GSAP 3 to distinguish between the two versions.


When you download the ZIP file none of the files should have a 3 at the end. So most likely the issue is that you're trying to import the files with 3s in the URL but they shouldn't be there. Does that make sense?

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...