Jump to content
Search Community

ScrollTrigger & Google Chrome

RobbieC test
Moderator Tag

Recommended Posts

Hi everyone,

I've been AFK for awhile but I'm kind of back¬†ūüėÜ!


This question is not directly related to GSAP but it's something I just came across and wanted to see if anyone else has ran into the same issue and what solution if any you used.


I didn't noticed this until I did a few things; I got a new mouse, hard drive and installed a fresh copy of windows 10 & Chrome. I opened my localhost on chrome and started scrolling with the mouse wheel and noticed that all my ScrollTrigger animations were super jumpy. I checked all my mouse settings, driver, etc and that didn't fix it. I do realize that the physical mouse wheel on some mouses move differently, so that's a little part of the issue.


The main issue I found was that in Google Chrome there is a feature called "Smooth Scrolling" you can find it at: chrome://flags/#smooth-scrolling

Mine was set to "default", I changed it to enabled and went back to my locahost and the jumping went away and the scrolling was smooth!!


I don't know if I had this featured enabled before on my old hard drive, so I'm not 100% sure if the issue was Chrome or if it was my new mouse or a combination of both.


My question to you guys is; do you have the feature enabled in Chrome?

If so, what do you do if a user/viewer does not have it enabled and the scroll animations are jumpy for them.


In the end, we all want the user to have the same viewing experience as the developer has when he builds something and if something like a feature in Google Chrome or even a curtain type of mouse can alter that viewing experience, what are the solutions (if any) so that everyone has the same viewing experience with the animations?

Link to comment
Share on other sites

Yes I have smooth scrolling enabled in Chrome.

12 hours ago, RobbieC said:

If so, what do you do if a user/viewer does not have it enabled and the scroll animations are jumpy for them.

There's only so much we can control. It's like these people that love to tell the tales of how they run around the web with JavaScript turned off and what a horrible experience it is for them. Well... turn your JavaScript on or you're gonna miss a whole lot of the web. The point being, users are gonna do what they do and I wouldn't lose too much sleep over it. Just my two cents. :)


  • Thanks 1
Link to comment
Share on other sites

23 minutes ago, PointC said:

Yes I have smooth scrolling enabled in Chrome.

Did you manually set it to enabled?


But yes what your saying does make sense. After I did a little more testing last night I came to realize that part of the jumping was caused by my actual mouse wheel, after testing it with my old mouse and laptop mouse, my new mouse's wheel has a longer roll per finger movement (I hope that makes sense). 


Just kind of sucks cause I didn't realize how much someone's settings/mouse could affect there viewing experience with scroll based animation. 


BUT if Chrome has there Smooth Scrolling feature set to enabled by default when someone installs Chrome for the first time, then this would not be an issue. Like with Firefox, its default set to use their build-in smooth scrolling. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...