Jump to content
Search Community

GSAP not working after server upload

Bratua test
Moderator Tag

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

Good day everyone. I have just completed my personal portfolio site which makes use of GSAP. However, it seems the animations are not playing and so the page remains blank. Everything works fine on my local server but when I uploaded my website to the dreamhost servers, the animations no longer work. There are no errors whatsoever on the console. I contacted the customer service and was told that in my error.log file it says the folder where all my GSAP.js files are located cannot be found. But looking at my panel, all files were uploaded successfully. Ok, in order to be sure it was not just the dreamhost servers, I decided to try uploading the site to github servers and still the same thing. The site and all files uploaded successfuly but the javascript files are not running or located. I don't know exactly. And after looking at the console and the network in the google developer tools, there is no single error, it shows all files were uploaded successfully as there is no error. What may be causing this issue? I'm lost.

Link to comment
Share on other sites

  • 2 years later...

I ended up here because I had an animation (with scrollTrigger and motionPath) that ran fine in a local html file in browser but appeared not run on my web servers. 


In my case, there was interference from a Google Extension called See (an accessibility related developer tool, link to their page in Google Play Store). After some futile efforts to debug (I noticed the gsap transforms were being overriden by another transform), I tried what I think you should try if you get here with this sort of issue: try your thing in an incognito session or incognito/private session in entirely different browser. I know you can run extensions in incognito so some of y'all cant rule out browser extension interference quite that easily.

TLDR If you are looking for a reason why your animations aren't running, check for extension interference. They can break gsap animations.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...