Jump to content
Search Community

Split Text not working on iPhone or in chrome

CarpeDiem test
Moderator Tag

Go to solution Solved by Jonathan,

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

I am very new at using the Split Text utility.  I was having fun with it and when i previewed my locally in browsers (Firefox, Safari and Chrome all was good.  But when I uploaded the file to a server, the animation did not work in chrome.  Also, the animation did not work on my iPhone.


I provided a link to my first code pen but when I hit run, it isn't even working at all.  I am using a local copy of the "SplitText.min.js"


Can anyone help?

See the Pen JGyVYX by anon (@anon) on CodePen

Link to comment
Share on other sites

Hi there,

I just edited the code pen and uploaded the SplitTest.js file.  It is still not working in code pen.


I no longer have the chrome problem but the animation is not working on my phone.


I don't know what I'm doing wrong in code pen.  As I said, this is my first try at using it

Link to comment
Share on other sites

SplitText will only work in CodePen if you include our special version of it: http://prntscr.com/9q2ulf. 

That is why we recommend that you fork our demos. You can see which scripts are being used by clicking on settings > JavaScript (or just click on the gear in the JS tab of the editor).


Please test this version that I made for you: http://codepen.io/GreenSock/pen/JGyVBN


Please confirm that it works in Chrome and on your phone. Thanks.

  • Like 1
Link to comment
Share on other sites

thanks carl.  i see that the code pen sample is indeed working and i am not having any trouble with my local file working in all desktop browsers but, when i put the folder with all the assets (the code pen example didn't include an image that i used) on a server and then try to access the link on my iPhone, i don't see the text animating the way i see it animating on desktop browsers.  does this make any sense to you?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...