Jump to content
Search Community

Brand New and weird problem

marlene test
Moderator Tag

Warning: Please note

This thread was started before GSAP 3 was released. Some information, especially the syntax, may be out of date for GSAP 3. Please see the GSAP 3 migration guide and release notes for more information about how to update the code to GSAP 3's syntax. 

Recommended Posts

After 2 hours trying to make some simple code work using the link that is commented out (first script link) but could not get it to work even after stripping down to very simple code.

I tried linking to a different script *the second script link) and everything worked like a charm. Does this make any sense?

1. <!--<script type="text/css" src="http://cdnjs.cloudflare.com/ajax/libs/gsap/latest/TweenMax.min.js"> </script>-->
2. <script src="http://cdnjs.cloudflare.com/ajax/libs/gsap/1.9.8/TweenMax.min.js"></script>


Link to comment
Share on other sites

The problem with the first one was that you're setting the type to "text/css" which is telling the browser to interpret it as css instead of JavaScript :)


The second one you left the "type" off completely, and browsers default to interpreting scripts as JavaScript, so it worked. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...